Skip to content
WP Intense Q & ACategory: Scalability Procan't fix "You have 1919 options set to autoload" following your guide
Mako K. asked 5 years ago

Hi,

I can't fix the "You have 1920 options set to autoload" issue following your instructions here:

https://www.wpintense.com/question/you-have-5892-options-set-to-autoload/

Because only one table is selected and modified. So after executing the SQL commands I now have 1919 options set to autoload instead of 1920. I modified the SQL commands you posted to reflect the fact that I changed the "wp" table prefix sitewise for security reasons. So I executed this command instead:

select left(option_name,15) option_name, count( * ) total from mymoddedprefix_options where autoload = 'yes' group by left(option_name,15) order by total desc;

I guess it should work this way, but it doesn't, so any help would be appreciated.

One more question. I see here:

https://www.wpintense.com/scalability-pro-guide/

that I should be able to create a full index status, but from your plugin options screen I only see a button to create a B-Tree Index Status, not a full one. Is it the same thing or is something wrong in my install?

Thank you for your help,

Alessio

1 Answers
Dave Hilditch Staff answered 5 years ago

For the full text index, please see the newly released BETA plugin for Super Speedy Search.

re: the options – the SELECT statement does not alter any content – you need to use the UPDATE statement to change the autoload=’yes’ to something else so they’re not loaded every page.

Use the SELECT statement to guide your decision about which plugins are loading 100s or 1000s of options and don’t need to (normally it’s obvious)

CYBERFUNDAY 40% discount coupon extended to Friday 9th December + join our Discord community and read the rules for an extra 20% discount coupon.