Skip to content
Stuart G. asked 8 months ago

Hi,

I updated to the latest beta version as i was waiting for a specific update.

I cannot get the widgets to display on any category page and when checking the error logs, I have an error saying ancestor table doesn't exist.

I have clicked the button 'Rebuild ancestors table and empty cache' within the advanced section, but i still get this error.

I have checked the database and the 'wpvq_fww_object_ancestors' is empty still. Does the ancestors table take a while to build? Or is there something blocking this / a setting configured incorrectly from my end?

Any help would be great.

Thanks,

Stuart G. replied 8 months ago

I’m not sure if this is the issue or not, but when i try and paste the ‘rebuild ancestor’ table sql into php my admin (within cPanel), it throws an error on the word ‘with’ next to ‘recursive relatedtax’.

Maybe this is why the table never gets created?

Thanks,

Dave H. Staff replied 8 months ago

Ah – the latest version of FWW requires MySQL 8 or MariaDB. You should ask your hosts to upgrade you.

If you want to use an older version, version 3.22 is the last version that doesn’t require MySQL 8.

I’m going to try and make a version that’s still fast that doesn’t require MySQL 8 or MariaDB.

Stuart G. replied 8 months ago

Hi Dave, I’ll check with my hosts to see if there will be any issues with upgrading to MYSQL8. Do you have a rough estimate of when the version that doesn’t require MYSQL8 would be available so i could let my client know in case we run into any issues upgrading to MYSQL8?

Thanks,

Dave H. Staff replied 8 months ago

I’ll try and add MySQL 5.6 compatibility by the end of April, but really you should upgrade – either MariaDB 10.2+ or MySQL 8+ – both give speed boosts to database queries, as well as elimination of intermittent slowdowns which happen with 5.6.

Stuart G. replied 8 months ago

Hi Dave,

We’ll look at upgrading to 8 its just there is so much functionality in the site we are afraid of upgrading and breaking other parts of the site. Our host warned us of this. I look forward to this version (for now)

Thanks

1 Answers
Dave Hilditch Staff answered 8 months ago

The latest version of FWW requires MySQL 8 or MariaDB. You should ask your hosts to upgrade you.

If you want to use an older version, version 3.22 is the last version that doesn’t require MySQL 8.

I’m going to try and make a version that’s still fast that doesn’t require MySQL 8 or MariaDB.

Please note: It’s possible to downgrade and keep your widget settings by installing an older ZIP file. You can find the older versions in https://www.wpintense.com/my-account/

Your Answer


CYBERFUNDAY 40% discount coupon extended to Friday 9th December + join our Discord community and read the rules for an extra 20% discount coupon.