Skip to content
WP Intense Q & ACategory: Scalability ProFASTER IMPORTS not working
Jan R. asked 7 months ago

Hello, we bought the plugin scalability pro to speed up our site. We import a large amount of data daily via wpallimport. Unfortunately, the FASTER IMPORTS - OPTIMISING WP_POSTMETA function has not had any noticeable effects so far. Why is that? I don't see any other settings in the backend. Can you help me there?

1 Answers
Dave Hilditch Staff answered 7 months ago
  1. Create the indexes with the create index button
  2. Enable the option to ‘defer term counts’

If your speed hasn’t improved, your biggest bottleneck was not coming from slow SQL – that means it’s likely coming from generating image sizes.

There’s an update coming to Scalability Pro to adjust image sizes created on imports per post-type, e.g. to only create 3 images if importing products.

In the meantime, this guide can help if that’s your issue:

https://www.wpintense.com/2017/05/31/speeding-wordpress-imports-datafeedr-wp-import/

Your Answer


CYBERFUNDAY 40% discount coupon extended to Friday 9th December + join our Discord community and read the rules for an extra 20% discount coupon.