Skip to content
WP Intense Q & ACategory: Super Speedy FiltersFWW Drop down not resetting (only on search results)
Jonathan L. asked 2 years ago

I am using the FWW categories wigdet to show a drop down on my category pages. The only problem is that on the search page, when you select a filter and then select a different category in the drop down, the dropdown selection is not resetting the filters.

I am using WPsolr w/ Algolia for this. If there is something you can do to make this work thats awesome but if not, can you please send me some info to send to the developer?

Krzysztof T. replied 2 years ago

Go to the widget page [Appearance > Widgets] and find the [FWW Product Categories Widget > Reset filters when category changes > Reset].

http://prntscr.com/ypitvh

Jonathan L. replied 2 years ago

Oh yeah, I tried that. Not working though.

Dave H. Staff replied 2 years ago

I’ve seen this in current beta – is it beta you’re using?

Patrik P. replied 2 years ago

This is for also ongoing problem. I was using 2.25 version. I recently tried 2.58..same story.

Patrik P. replied 2 years ago

So I think I partialy found solution. In version 2.25 you have to create new home page. In other words make sure that your “shop” page is not your home page. The latest 2.46 is not the yet and it is doubling variations: domain/filter/variable1/variable1 , while 2.25 is working fine : domain/filter/variable1/

Dave H. Staff replied 2 years ago

Ah – ok, interesting that you found 2 bugs here: shop as home page is not working (I think I know why, I’ll implement a fix) and 2nd bug that variations are being doubled?

Can you explain more on the variations being doubled? That shouldn’t happen. Is this also from the shop home page?

Dave H. Staff replied 2 years ago

I guess you mean ‘filters’ being doubled, like /filter/black/black ? If so, can you confirm this is only happening when you have the shop as your home page? It’ll help me massively in tracking down this bug.

Patrik P. replied 2 years ago

No it is on going thing. I reinstalled /autoupgaded/ and double-ing of variations occured on 2.46 version, despite the fact, that I created a new home page. I need to mention, that I even deleted plugin and reuploaded 2.46

Patrik P. replied 2 years ago

reuploaded 2.46 via uploader and not autoupdate.

Patrik P. replied 2 years ago

I also would like to mention that I am not using any “brand” plugins- My brands are “stored” in one of the variation. I am usually using 3 variations /brand, type, color/. So you can imagine that url mess this plugin is throwing once you start to drill down the widgets, deleting filters /reseting filters/…it is just a mess.

It grabs and recreates urls like: domain/filter/variable1/variable1

if you reset filters it goes to:

domain/filter/variable1/variable1/filter/variable1/variable1

and so on…

Dave H. Staff replied 2 years ago

Ok – when you say ‘variations’ you actually mean ‘attributes’ – right? But yeah, it really should not be doubling the attributes.

I’ve not seen this elsewhere – to figure it out I’ll need FTP and wp-admin access – can you update this question with credentials to access your site? (add them in the private area, not public!)

Dave H. Staff replied 2 years ago

Off the top of my head, the only thing I can think might cause something like this is the ‘trailing slash’ feature in WordPress – do you have trailing slashes disabled? e.g. do your site URLs always end with a slash or always end without a slash?

Patrik P. replied 2 years ago

Little off-topic, but your last 2 comments /”Ok – when you say ‘variations’…”, “Off the top of my head”/ on this thread delivered 10 emails to my inbox. So frankly, I am not really digging: “I’ve not seen this elsewhere”…:D

See image below:
https://imgur.com/kvwOHLp

And yes I mean attributes.

And yes all my wordpress URLS ends with trailing. All of them.

Patrik P. replied 2 years ago

Ok, so on that web I have general categories widget area /list view/.

I also have additional products that are not assigned to those general categories. Drop down menu “brands” /try brand “detecha” for example/.

The only thing I changed is: “Display current category as removable filter” to “Yes”…

…and here we go again…But “general categories” filter cleaning is working… Only if I go to brand that has no category assigned throws this error…

I think we found the reason /no no-trailing slash/, but if no category is assigned filer reset goes south…

I have websites that using only attributes…they dont have categories. I dont want to use categories I can pair /or no pair/ via attributes much better and websites seems faster.

1 Answers
Dave Hilditch Staff answered 2 years ago

If anyone experiences ‘doubling of attributes’ or weird issues like filters not resetting, please ensure you have updated Faster Woo Widgets to the latest version (current latest is 2.46 beta) and then visit the settings -> Faster Woo Widgets page and click the ‘Clear Cache’ button.

https://i.imgur.com/vH1Iy0Q.png

The FWW cache is a fragmented cache which remembers generated URLs for filter combos according to the settings you have in FWW. Another way to clear this cache is altering any of the settings for Faster Woo Widgets.

Patrick – please try your site now, and also please can you tell me what this says?

https://i.imgur.com/GYHJq3e.png

It looks like your doubling of attributes bug is gone completely now that the FWW cache is cleared, but the ‘active filters’ is acting a little odd. Please translate that for me, so I can figure out if it’s specific to your config.

OP Jonathan, can you confirm the resetting bug is gone when you clear the FWW cache?

Patrik P. replied 2 years ago

it means clear filters.

Patrik P. replied 2 years ago

Yeah, so long story short: If your select attribute from dropdown, that has no category assigned…doubling is happening https://imgur.com/a/zsZ2Pux

Your Answer


CYBERFUNDAY 40% discount coupon extended to Friday 9th December + join our Discord community and read the rules for an extra 20% discount coupon.