Skip to content
Neo n. asked 1 year ago

Hi there,

i have a very urgent situation, after uplouading a beta version 3.30 of FWW plugin on my site, the filter by category is active in the backend, but not visible in the frontend. I tried to upload older version of FWW, but the same situation there.

I urgently need youe assistance, please!

Thank you in adavnce.

1 Answers
Dave Hilditch Staff answered 1 year ago

Sounds like you upgraded to this from a much older version.

  1. You need MySQL 8 or MariaDB to use the latest versions
  2. On first install, it will create helper tables. Once these are created your filters will be back. It takes about 3 minutes to create these on foundthru with 900,000 products.

If you do not have MySQL 8 or MariaDB, you will need to rollback to an older version like 3.21 where MySQL 8 was not yet required.

I will release an update soon which will allow you to query the database in the old way AND in the new way which will provide a solution for people without MySQL 8 and also it will prevent your filters going offline in the first activation of the update while the supporting tables are being built.

Dave H. Staff replied 1 year ago

If you are saying that attribute filters are working but the category one is not, can you please try saving the widget again? Also, check the visibility settings, parent term restrictions (should be 0 by default) and other filter dependency (e.g. requiring another attribute to be set before displaying).

If none of these solve it, activate query monitor, clear your object cache and load a page where the category filter is supposed to appear. Maybe Query Monitor comes up with a red warning? If so, click that and send me a copy of the database error.

Neo n. replied 1 year ago

HI Dave,
My site is using server version: 10.3.32-MariaDB

When category filter doesnt work – all attributes filters dont work. Only Price and on sale widget are visible.

I also noticed that filters disappear when I upload a bit amount of mew products. After that I go to the database, delete fww_ancestors_updated_time and fww_ancestors_populated tables, return to FWW settings page – the ancestors rebuild starts again.

Rebuild ancestors doesnt work though when I click the corresponding button in FWW settings.

Dave H. Staff replied 12 months ago

I’ve created a Trello card here: https://trello.com/c/9H9uXS8Y/270-rebuild-ancestors-not-working-on-mariadb

Can you please send me access details for your server to me through Discord? I suspect there may be one of the SQL commands needs a slightly different format for MariaDB, but I can fix that quickly if you provide access.

Your Answer


Click to join our Discord community and read the rules for a 20% discount coupon. Coupon usable once per customer only.