Site not fast enough after install wpi performance

WP Intense Q & ACategory: Scalability ProSite not fast enough after install wpi performance
Coen asked 6 months ago

Hi Dave,

We have been in contact a couple of times about our site dev.designmeubelen.nl and you made the stack for that site. After installing the wpi performance plugin, most of the pages and filters do still not load fast. I tried to contact you by email, but did not yet see a reply, so hereby via the Q&A.

What can we do to make this faster?

Hope to hear from you soon.

Kind regards,

Coen

Vasil Yordanov replied 6 months ago

Greetings Coen, apologies for the delay. Some clients indeed seem to be experiencing slow loading and searches even after installing the Performance Plugin. We are currently investigating the causes behind this and will make sure to roll out a fix as soon as possible. In the meantime, I will make sure to follow up with you and give you frequent updates as we go. Thank you for your patience and understanding.

Coen replied 6 months ago

Hi Vasil,

thank you so much for your reply and do you have an expectation when the update will be finished and do you need in any change the login / details from my website to have a look, perhaps that can help in solving the problem. We are using for this site you your wpi Fast WordPress stack, so it should not be the hosting.

Hope to hear from you soon.

Kind regards,

Coen

Vasil Yordanov replied 6 months ago

Hi Coen. I’m afraid that I don’t quite have an ETA on the update yet, I’d be lying if I gave you some date. Dave is, however, trying to roll it out as soon as possible and fix any of the remaining issues around the performance plugin, I don’t think it will be longer than a week or so. I will also make sure to ask Dave if having a look around the website for testing purpose would help speed up the process, thank you for offering.

Coen replied 6 months ago

Ok no worries and then I will keep an eye on the progress and will be waiting for your reply

Coen replied 6 months ago

Hi Vasil, can you give me an update on the plugin? Thanks

Vasil Yordanov replied 6 months ago

Yes. Yours seems to be a singular issue, thus I suspect it’s another problem entirely. We will need to have a look at your website – if you can give us access to it here in a private message, I will make sure Dave has a look at it.

3 Answers
Coen answered 6 months ago

O yeah I sended the following email:

this morning we have been testing with the WPI performance plugin and at the moment it looks like it is going quicker, but it is still not loading quick enough. I get now load times between 1 and 10 seconds by filters and categories. We are running the test at the moment at: http://dev.designmeubelen.nl/.

At the top we have a menu with meubels (with the menu function) and when you click on those menu items it does not go quickly and also the filters and subcategories are still loading pretty long. Could you have a look and let me know if this should be the loading time or that it normally should go quicker? In the configuration of the module i tried by sort order and calculate totals for current page both quickest and slowest, but it did not seem to make a huge differents.

Next to that, is there also a function that you only show the subcategories when you go to a category? With the normal functionality in woocommerce you can choose to only show underlying categories and this is better for seo.

Dave Hilditch Staff answered 6 months ago

Hi – to make full use of the WPI performance plugin, please visit the settings page and:

1) Create the full text index

2) Create the b-tree indexes

3) Choose the other options you wish which will speed up your site

https://dev.designmeubelen.nl/wp-admin/options-general.php?page=wpi_performance

Coen replied 6 months ago

Hi Dave,

thanks for your reply and just directly made the changes (bit stupid that I didn’t make them before). Now I put everything on the fastest way and created the full text and b-tree indexes, but to my experience it does not make a difference in speed. When I click a filter it keeps loading.

Can it be that there are still settings wrong or do you have any idea how to get it faster?

Hope to hear from you soon.

Kind regards,

Coen

Coen replied 6 months ago

Hi Dave / Vasil

Did you read my last reply on your feedback and can you come back on this. I made the changes, only don’t see a difference yet. I will send you in a new answer two printscreens from the settings.

Kind regards,

Coen

Coen replied 6 months ago

Hi Dave / Vasil

Did you read my last reply on your feedback and can you come back on this. I made the changes, only don’t see a difference yet. I will send you in a new answer two printscreens from the settings.

Kind regards,

Coen

Vasil Yordanov answered 5 months ago

Hey Coen,

am I understanding correctly – you see absolutely no improvement even after implementing Dave’s configurations?

Coen replied 5 months ago

Hi Vasil,

thanks for your reply and it does make a difference, but there are still quite some spots where it is not super fast. I have been reading your post about the AVADA theme and we are using ourself the https://themeforest.net/item/flatsome-multipurpose-responsive-woocommerce-theme/5484319?s_rank=1 (number one on themeforest for ecommerce). Can it be that perhaps there are things in the theme that slow it down. Do you perhaps have recommendations on themes that you guys have good experiences with that are very fast for Woocommerce, then I would first like to try a different theme to see if that makes any difference.

Hope to hear from you soon.

Kind regards,

Coen

Vasil Yordanov replied 5 months ago

I’ll get back to you about that very soon, going to have a chat with Dave about it and see what can be done.

Coen replied 5 months ago

Thanks, as an example I just had a subcategory that loaded for instance in 17,8 seconds (with me logged in so logged out that will go faster). If you guys have some good themes that you think good work, I would like to try that. Hope to hear from you

Coen replied 5 months ago

Hi Vasil,

did you get any reply on the template?

let me know.

Thanks

Dave Hilditch Staff replied 5 months ago

Can you tell me if you get the options warning on the Settings->WPI Performance page? If so, you have too many options loaded. If you can follow the guide for the Avada theme and delete any extra options you don’t need then you’ll get far better speed.

Coen replied 5 months ago

Hi Dave,

thanks for your reply and have just been bissy with it this mornin. I didn’t see an options warning if I am correct, at least didn’t see it at the top.

I said it wrong we are using the Flatsome theme at the moment, that is the most used Woocommerce theme on themeforest: https://themeforest.net/item/flatsome-multipurpose-responsive-woocommerce-theme/5484319. Perhaps there are things in that theme that are not working correctly, could that be. Do you have in any change other woocommerce themes that you have used before that I could try? I am willing to change themes if that would solve the problem.

I also just changed from w3total cache to wp super cache, just to see if that could help. Looks like cached pages do work better now, but when they are not cached (for instance first time you load a subcategory), it is just really different. Sometimes it loads in miliseconds and sometimes it takes pretty long (so up to 10 / 15 seconds).

Let me know if you know a theme that should be really fast.

Kind regards,

Coen

Coen replied 5 months ago

Btw I do think it is a theme related thing, because I have just installed Avada to test the speed with that theme (and your bug fixes for that theme) and that looks like it is going faster. So would be great if you could reply on the theme question

Coen replied 5 months ago

Hi Dave,
Today I have worked again on the site and was thinking going to get it online with the Avada theme in combination with your stack, but today again I am getting page loading times between 5 and 15 seconds for categories and filters. I honestly don’t want to border you this much, but at the moment it is just not possible to go live with those times. I am now using your wpi fast wordpress stack, is there any other option that could be better (don’t think so), because I don’t really understand what is now still slowing the site down.

I put all the settings on fastest and also renewed the indexes. Since the last time I did run the Datafeedr product sets again, but now disabled updates so that can also not intervier the speed.

Hope to hear from you soon.

Kind regards,

Coen

Kind regards,

Coen

  • Hullo and welcome! Chat directly to the site owners below.
Latest Message: