Troublshooting

don asked 11 months ago

Just purchased the plugin & have this error. Also nothing shows up under the settings/plugin page, not sure if theur is suppose to be or not.

Warning: Invalid argument supplied for foreach() in /wp-content/plugins/wpi-performance-plugin/wpi-performance-plugin.php on line 1320

Thanks

4 Answers
Dave Hilditch answered 11 months ago

There was an update released yesterday which adds info to the settings page. There is an update coming out tomorrow which will include some options for this page, including the ability to switch query caching on/off, view index status and some other options to switch on/off various speed boosts.

The warning you’re seeing is just a warning and does not affect functionality, but it will also be fixed in the coming update.

Thank you for the report.

don replied 10 months ago

Which update & when? I understand it’s just a warning, but I don’t want that on my website, at the top.

Dave Hilditch replied 10 months ago

The quickest workaround to get rid of the warning is to switch off debug mode in your wp-config.php file. The next update is hopefully coming out tonight. Working on final testing right now.

Darren answered 10 months ago

Hi Dave – Ive just installed the plugin and get an error message when I try to activate it;

The plugin generated 316 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.

When I then attempt to cvlick into the Options page I see this at thew bottom of the page;

Warning: Missing argument 2 for wp_update_term_count(), called in /home4/luxwtch/public_html/bestairrifles/wp-content/plugins/wpi-performance-plugin/wpi-performance-plugin.php on line 71 and defined in /home4/luxwtch/public_html/bestairrifles/wp-includes/taxonomy.php on line 3576

Darren replied 10 months ago

Any update on this please Dave- I just read your email and it’s suggested this is the best way to reach out for support – I trust I’m posting this in tyhe correct section of your Q&A?

Dave Hilditch replied 10 months ago

Yes – sorry – I was busy getting all the bug fixes and feature requests from everyone into this release

Dave Hilditch answered 10 months ago

Please update to the latest version 2.7 where these warnings are all fixed. You will need to activate the plugin in order to update it – since you’re getting an error on activation, you’ll need to activate, then reload /wp-admin/ again and the errors won’t be there, navigate to the plugins section, check for updates, then click to update.

Darren answered 10 months ago

Hi again Dave – did that and that did indeed apply the update however now as soon as the plugin is activatyed I now get a site wide error on public and admin sites of this;

Fatal error: Call to undefined function wc_get_page_id() in /home4/luxwtch/public_html/bestairrifles/wp-content/plugins/wpi-performance-plugin/wpi-performance-plugin.php on line 1941

Going to try a different theme and disabling wp-caching to see if that makes a difference but please advise what else I can be doing.

Dave Hilditch replied 10 months ago

Ive emailed you an updated file. Please upload this file using SFTP and overwrite the existing file. Not sure how this didn’t happen in my non-woo test env.

  • Hullo and welcome! Chat directly to the site owners below.
Latest Message: