2020-06-23_16-54-50

Some images are not displayed

18 Comments

  1. Martin H.
    June 23, 2020 @ 4:12 pm

    Images are imported through WP All import to custom field external_image_url

    Reply

  2. Dave H.
    June 24, 2020 @ 12:39 pm

    Please update to 2.44 and re-run the DB update. I’ve tested these two combos and there’s no good reason why they are not being saved properly so I think it may be an issue with the ‘ei_converted’ marker that tells the plugin that the images have been converted to arrays from the input field external_image_url.

    This ei_converted field gets reset whenever the external_image_url meta field is updated – can you confirm you are allowing wp all import to run the do_action calls? If you are not, please update a separate meta field in your imports called:

    ei_converted

    And set it to 0 (zero).

    Reply

  3. Martin H.
    June 24, 2020 @ 1:24 pm

    do_action call is allowed
    Now more images are displayed, but still not all.
    Some products display only featured image (not products gallery) even though external_image_url contains multiple images.
    https://www.screencast.com/t/tFGbvv16UQ
    Some products display second imported image (not first) as featured image
    Product: https://kupelneonline.sk/vodovodne-baterie/vanove-baterie/pakove-nastenne/ideal-standard-ceramix-style-4/
    external_image_url: https://kupelneonline.sk/wp-content/uploads/detailed_images/detailed_image_491.jpg|https://kupelneonline.sk/wp-content/uploads/detailed_images/detailed_image_492.jpg

    Reply

  4. Dave H.
    June 24, 2020 @ 1:50 pm

    I’ll need to dig into this further – can you please create a ticket referencing this bug report URL and provide wp-admin and ideally SFTP access?

    I’ll figure out what’s going wrong for you.

    Reply

    • Martin H.
      June 24, 2020 @ 2:15 pm

      Please, write me your e-mail for account creation.

      Reply

  5. Dave H.
    June 24, 2020 @ 2:33 pm

    Failing that, please try version 2.46 – I have refactored the code in the conversion process to be a very simple single code path and have tested it on 3 sites and see no failures.

    Reply

  6. Martin H.
    June 24, 2020 @ 3:57 pm

    Still some featured images are not displayed
    ei_converted meta for these products is still 0
    https://www.screencast.com/t/Afaayqljr

    Product image gallery still not displayed for some newly imported products

    Reply

  7. Martin H.
    June 24, 2020 @ 4:03 pm

    Hundreds of recurring entries in debug.log

    PHP Notice: Undefined variable: image_meta in /wp-content/plugins/external-images_/includes/class-external-images-admin.php on line 441
    PHP Notice: Undefined variable: image_meta in /wp-content/plugins/external-images_/includes/class-external-images-admin.php on line 411

    Reply

  8. Dave H.
    June 24, 2020 @ 5:38 pm

    Can you confirm version 2.46? Also, please confirm you only have 1 of the plugins installed – it’s a little odd the plugin is installed in the external-images_ folder (not the suffix underscore)

    I have a completely different line on line 441 so I’m pretty sure this will clear up if you check for updates for the plugin and update and ensure there’s only 1 plugin running.

    Reply

    • Martin H.
      June 26, 2020 @ 10:41 am

      Hi. Something new?

      Reply

  9. Martin H.
    June 24, 2020 @ 6:02 pm

    Reply

  10. Martin H.
    June 26, 2020 @ 10:58 am

    Is it possible than image is not processed if is smaller than some size? Under 300 x 300 px?

    Reply

    • Dave H.
      June 30, 2020 @ 2:05 pm

      Please check the latest version – I’ve removed the use of the getimagesize function which is where I think this problem may have been coming from.

      Reply

  11. Martin H.
    June 26, 2020 @ 11:23 am

    This is in backend: https://www.screencast.com/t/LnSev8NVG

    getimagesize(https://kupelneonline.sk/wp-content/uploads/detailed_images/image-3186-tilezza-barca.jpg): failed to open stream: HTTP request failed! HTTP/1.0 403 Forbidden

    wp-content/plugins/external-images/includes/class-external-images-admin.php:369

    Reply

  12. Dave H.
    June 29, 2020 @ 2:16 pm

    I think there’s an issue with your hosting blocking the remote getimagesize function.

    Can you check with your hosting company?

    I’m investigating a workaround to avoid using getimagesize in the meantime.

    Reply

  13. Martin H.
    June 29, 2020 @ 2:27 pm

    Yes. This function is disabled and unfortunately cannot be enabled. 🙁

    Reply

  14. Dave H.
    June 29, 2020 @ 3:16 pm

    I’ve released an update which avoids using the getimagesize function. Please upgrade to 2.48 and you should find it works perfectly for you now.

    Reply

    • Martin
      June 30, 2020 @ 7:02 pm

      Great. Now it works 🙂 Thank you!

      Reply

Leave a Reply

Your email address will not be published. Required fields are marked *

We use cookies

We use cookies for various things on our site, including our on-site chat bubble (if you use it), our comment forms (if you use them) and for session handling (if you log in).

Other than that, we use cookies to identify where traffic came from to help us understand which traffic turns into sales, we use a cookie for Google Analytics traffic analysis and we use a cookie to customise adverts for our own products we think you'll be interested in.

You can read more detail in our privacy policy page. Please click 'Accept' or 'Decline' to continue.